Tuesday, April 19, 2016

BGP-iBGP



R1 Config
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 12.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 12.1.1.2 remote-as 100
 neighbor 12.1.1.3 remote-as 100
 neighbor 12.1.1.4 remote-as 100
 no auto-summary

R2 Config
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 12.1.1.2 255.255.255.0
 duplex auto
 speed auto
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 2.2.2.0 mask 255.255.255.0
 neighbor 12.1.1.1 remote-as 100
 neighbor 12.1.1.3 remote-as 100
 neighbor 12.1.1.4 remote-as 100
 no auto-summary
!

R3 Config
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 12.1.1.3 255.255.255.0
 duplex auto
 speed auto
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.0 mask 255.255.255.0
 neighbor 12.1.1.1 remote-as 100
 neighbor 12.1.1.2 remote-as 100
 neighbor 12.1.1.4 remote-as 100
 no auto-summary
!

R4 Config
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!
interface FastEthernet0/0
 ip address 12.1.1.4 255.255.255.0
 duplex auto
 speed auto
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.0 mask 255.255.255.0
 neighbor 12.1.1.1 remote-as 100
 neighbor 12.1.1.2 remote-as 100
 neighbor 12.1.1.3 remote-as 100
 no auto-summary
!

*Mar  1 00:05:28.631: BGP: 12.1.1.1 went from Idle to Active
*Mar  1 00:05:28.639: BGP: 12.1.1.1 open active delayed 34036ms (35000ms max, 28% jitter)
*Mar  1 00:05:52.055: BGP: 12.1.1.1 passive open to 12.1.1.4
*Mar  1 00:05:52.055: BGP: 12.1.1.1 went from Active to Idle
*Mar  1 00:05:52.055: BGP: 12.1.1.1 went from Idle to Connect

*Mar  1 00:05:52.063: BGP: 12.1.1.1 rcv message type 1, length (excl. header) 26
*Mar  1 00:05:52.067: BGP: 12.1.1.1 rcv OPEN, version 4, holdtime 180 seconds
*Mar  1 00:05:52.067: BGP: 12.1.1.1 went from Connect to OpenSent
*Mar  1 00:05:52.067: BGP: 12.1.1.1 sending OPEN, version 4, my as: 100, holdtime 180 seconds
*Mar  1 00:05:52.067: BGP: 12.1.1.1 rcv OPEN w/ OPTION parameter len: 16
*Mar  1 00:05:52.067: BGP: 12.1.1.1 rcvd OPEN w/ optional parameter type 2 (Capability) len 6
*Mar  1 00:05:52.071: BGP: 12.1.1.1 OPEN has CAPABILITY code: 1, length 4
*Mar  1 00:05:52.071: BGP: 12.1.1.1 OPEN has MP_EXT CAP for afi/safi: 1/1
*Mar  1 00:05:52.071: BGP: 12.1.1.1 rcvd OPEN w/ optional parameter type 2 (Capability) len 2
*Mar  1 00:05:52.071: BGP: 12.1.1.1 OPEN has CAPABILITY code: 128, length
*Mar  1 00:05:52.071: BGP: 12.1.1.1 OPEN has ROUTE-REFRESH capability(old) for all address-families
*Mar  1 00:05:52.075: BGP: 12.1.1.1 rcvd OPEN w/ optional parameter type 2 (Capability) len 2
*Mar  1 00:05:52.075: BGP: 12.1.1.1 OPEN has CAPABILITY code: 2, length 0
*Mar  1 00:05:52.075: BGP: 12.1.1.1 OPEN has ROUTE-REFRESH capability(new) for all address-families
*Mar  1 00:05:52.075: BGP: 12.1.1.1 went from OpenSent to OpenConfirm
*Mar  1 00:05:52.079: BGP: 12.1.1.1 send message type 1, length (incl. header) 45
*Mar  1 00:05:52.151: BGP: 12.1.1.1 went from OpenConfirm to Established


==============================================================================


R1#show ip bgp neighbors 12.1.1.3
BGP neighbor is 12.1.1.3,  remote AS 100, internal link
  BGP version 4, remote router ID 3.3.3.3

  BGP state = Established, up for 00:08:15
  Last read 00:00:15, last write 00:00:15, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                1          1
    Keepalives:            11         11
    Route Refresh:          0          0
    Total:                 13         13
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP table version 5, neighbor version 5/0
 Output queue size : 0
  Index 1, Offset 0, Mask 0x2
  1 update-group member
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               1          1
(Consumes 52 bytes)
    Prefixes Total:                 1          1
    Implicit Withdraw:              1          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          1
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Bestpath from iBGP peer:              3        n/a
    Total:                                3          0
  Number of NLRIs in the update sent: max 1, min 1

  Connections established 1; dropped 0
  Last reset never
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 255
Local host: 12.1.1.1, Local port: 41981
Foreign host: 12.1.1.3, Foreign port: 179








R2 Config
router bgp 100
neighbor 25.1.1.5 remote-as 54

R2(config-router)#do show ip bgp nei 25.1.1.5
BGP neighbor is 25.1.1.5,  remote AS 54, external link
  BGP version 4, remote router ID 25.1.1.5
  BGP state = Established, up for 00:02:34
  Last read 00:00:20, last write 00:00:33, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1
Local host: 25.1.1.2, Local port: 13280
Foreign host: 25.1.1.5, Foreign port: 179





Saturday, April 16, 2016

DMVPN Configuration




DMVPN is point-to-point layer3 overlay VPN:
logical hub and spoke topology

Multipoint GRE tunnel
NHRP
IPSec Crypto Profile

DMVPN HUB/ NHRP Server
DMVPN Spoke/ NHRP Client

NHRP Messages
- Registration Request
- Resolution request
- Redirect

R1(config-if)#
interface Tunnel0
 ip address 10.1.1.1 255.255.255.0
 no ip redirects
 ip nhrp authentication cisco
 ip nhrp map multicast dynamic
 ip nhrp network-id 100
 no ip split-horizon
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 100
!
interface FastEthernet0/0
 ip address 12.1.1.1 255.255.255.0
 duplex auto
 speed auto

R2(config-if)#
interface Tunnel0
 ip address 10.1.1.2 255.255.255.0
 ip nhrp authentication cisco
 ip nhrp map 10.1.1.1 12.1.1.1
 ip nhrp map multicast 12.1.1.1
 ip nhrp network-id 100
 ip nhrp nhs 10.1.1.1
 tunnel source FastEthernet0/0
 tunnel destination 12.1.1.1
 tunnel key 100
!
interface FastEthernet0/0
 ip address 12.1.1.2 255.255.255.0
 duplex auto
 speed auto

R3(config-if)#
!
interface Tunnel0
 ip address 10.1.1.3 255.255.255.0
 ip nhrp authentication cisco
 ip nhrp map 10.1.1.1 12.1.1.1
 ip nhrp map multicast 12.1.1.1
 ip nhrp network-id 100
 ip nhrp nhs 10.1.1.1
 tunnel source FastEthernet0/0
 tunnel destination 12.1.1.1
 tunnel key 100
!
interface FastEthernet0/0
 ip address 12.1.1.3 255.255.255.0
 duplex auto
 speed auto

router rip
 version 2
 network 1.0.0.0
 network 10.0.0.0
 no auto-summary












Now change the configuration of the spoke router to gre mode multipoint the spoke router will now be able to talk to each other directly without routing the packet via HUB.

R3(config-if)#
!
interface Tunnel0
no tunnel destination 12.1.1.1
 tunnel mode gre multipoint




DMVPN Phase-3
#ip nhrp redirect :- configured on the hub, which informs to the spoke that it can communicate to other intended spoke directly.

#ip nhrp shortcut :- configured on the spoke which is responsible to rewrite the CEF entry after getting the redirect message from hub.