Sunday, July 24, 2016

Multicast-Filtering BSR Messages

BSR messages are carried inside PIM. When you apply the command  ip pim bsr-border on a link, BSR messages are no longer flooded or received on that link.

#ip pim bsr-border

Multicast-PIM Bootstrap Router


The Bootstrap Router (BSR) is a mechanism for a router to learn RP information. It ensures that all routers in the PIM domain have the same RP cache as the BSR.

BSR is standard-based protocol available with PIMv2. The information is flooded using PIM messages If the RPF check succeeds, the message is flooded out of all PIM-enabled interfaces until all routers in the domain learn the information.



R2#
ip multicast-routing
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
 ip pim sparse-mode
!
interface FastEthernet0/0
 ip address 200.1.1.2 255.255.255.0
 ip pim sparse-mode
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 ip pim sparse-mode
 duplex auto
 speed auto
!
router ospf 10
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip pim send-rp-announce Loopback0 scope 255
!

R1(config)#ip pim bsr-candidate lo0



R5(config)#
interface Loopback0
 ip address 5.5.5.5 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 224.10.10.10
end


R1#ping 224.10.10.10
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.10.10.10, timeout is 2 seconds:
Reply to request 0 from 45.1.1.5, 120 ms
Reply to request 0 from 45.1.1.5, 156 ms











Saturday, July 23, 2016

Multicast-PIM Accept Register

Rendezvous Point are specifies the sources that are allowed to register with the RP. Every register message contains the original multicast packet, which includes the IP address of the multicast source and the group destination address. If the RP denies the registration, it sends a PIM Register-Stop to the DR immediately and never builds the SPT toward the source.

By default all sources are allowed to register at the RP (Rendezvous Point) when using PIM sparse mode.
This PIM register message contains the original multicast packet from the source, and it includes the IP address of the source and the destination multicast group address. RP can be configured to filter certain sources, RP will send a PIM register-stop message to the PIM DR so that it will not build the SPT towards the source.



R2 #
ip multicast-routing
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 12.1.1.2 255.255.255.0
 ip pim sparse-mode
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 23.1.1.2 255.255.255.0
 ip pim sparse-mode
 duplex auto
 speed auto
!
ip pim rp-address 2.2.2.2
ip pim accept-register list DENY-REGISTER
!
ip access-list extended DENY-REGISTER
 permit ip host 1.1.1.1 224.10.10.0 0.0.0.255
 deny   ip any any



R4#
R4(config-if)#do show run int lo0
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
 ip igmp join-group 224.10.10.10
 ip igmp join-group 224.44.44.44
end









R1#ping 224.44.44.44