MSDP or Multicast Source Discovery Protocol is used to exchange multicast source information between RPs. A TCP connection between the RPs and used to exchange the so-called Source Active (SA) messages. Each domain usually has its own RP. To allow sources and receivers from different domains to locate each other, RPs need to exchange the information about their local active sources.
Anycast RP is a special RP redundancy scenario that allows using redundant RPs sharing the sameIP address. Here, Anycast means that groups of RPs use the same IP address used by all multicast routers in the domain to build shared trees. However, the PIM Joins are being sent to the closest RP, based on the unicast routing table.
R2#
interface Loopback0
ip address 25.25.25.25 255.255.255.0
ip pim sparse-mode
!
interface Loopback1
ip address 200.200.200.200 255.255.255.0
!
interface FastEthernet0/0
ip address 23.1.1.2 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip pim rp-candidate Loopback0
R5#
interface Loopback0
ip address 25.25.25.25 255.255.255.0
ip pim sparse-mode
!
interface FastEthernet0/0
ip address 45.1.1.5 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip pim rp-candidate Loopback0
R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip pim sparse-mode
!
interface FastEthernet0/0
ip address 13.1.1.3 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 34.1.1.3 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 23.1.1.3 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip pim bsr-candidate Loopback0 0
R6(config)#int f0/0
R6(config-if)#ip igmp join-group 224.1.1.1
R2#
int lo2
ip add 22.22.22.22 255.255.255.0
!
R2(config-if)#ip msdp originator-id lo2
R2(config)#ip msdp peer 55.55.55.55 connect-source lo2
R5#
int lo2
ip add 55.55.55.55 255.255.255.0
!
R5(config-if)#ip msdp originator-id lo2
R5(config)#ip msdp peer 22.22.22.22 connect-source lo2
Anycast RP is a special RP redundancy scenario that allows using redundant RPs sharing the sameIP address. Here, Anycast means that groups of RPs use the same IP address used by all multicast routers in the domain to build shared trees. However, the PIM Joins are being sent to the closest RP, based on the unicast routing table.
R2#
interface Loopback0
ip address 25.25.25.25 255.255.255.0
ip pim sparse-mode
!
interface Loopback1
ip address 200.200.200.200 255.255.255.0
!
interface FastEthernet0/0
ip address 23.1.1.2 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip pim rp-candidate Loopback0
R5#
interface Loopback0
ip address 25.25.25.25 255.255.255.0
ip pim sparse-mode
!
interface FastEthernet0/0
ip address 45.1.1.5 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip pim rp-candidate Loopback0
R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip pim sparse-mode
!
interface FastEthernet0/0
ip address 13.1.1.3 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 34.1.1.3 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 23.1.1.3 255.255.255.0
ip pim sparse-mode
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip pim bsr-candidate Loopback0 0
R6(config)#int f0/0
R6(config-if)#ip igmp join-group 224.1.1.1
R2#
int lo2
ip add 22.22.22.22 255.255.255.0
!
R2(config-if)#ip msdp originator-id lo2
R2(config)#ip msdp peer 55.55.55.55 connect-source lo2
R5#
int lo2
ip add 55.55.55.55 255.255.255.0
!
R5(config-if)#ip msdp originator-id lo2
R5(config)#ip msdp peer 22.22.22.22 connect-source lo2
No comments:
Post a Comment