The EIGRP stub feature is used to limit the scope of EIGRP query messages and to further limit which routes a neighbor advertises.
EIGRP Timer
R1!#
interface fa0/0
ip hello-interval eigrp 100 1
ip hold-time eigrp 100 3
R1#router eigrp 100
eigrp stub connected
R2(config-router)#
ip access-list extended EIGRP-LEAK
permit ip 1.1.1.0 0.0.0.255 any
permit ip 1.1.2.0 0.0.0.255 any
!
route-map EIGRP-MAP permit 10
match ip address EIGRP-LEAK
!
router eigrp 100
network 2.2.2.0 0.0.0.255
network 12.1.1.0 0.0.0.255
network 23.1.1.0 0.0.0.255
auto-summary
eigrp stub connected leak-map EIGRP-MAP
EIGRP Timer
R1!#
interface fa0/0
ip hello-interval eigrp 100 1
ip hold-time eigrp 100 3
R1#router eigrp 100
eigrp stub connected
- Receive-only: The stub router will not advertise any network.
- Connected: allows the stub router to advertise directly connected networks.
- Static: allows the stub router to advertise static routes (you have to redistribute them).
- Summary: allows the stub router to advertise summary routes.
- Redistribute:allows the stub router to advertise redistributed routes.
R2(config-router)#
ip access-list extended EIGRP-LEAK
permit ip 1.1.1.0 0.0.0.255 any
permit ip 1.1.2.0 0.0.0.255 any
!
route-map EIGRP-MAP permit 10
match ip address EIGRP-LEAK
!
router eigrp 100
network 2.2.2.0 0.0.0.255
network 12.1.1.0 0.0.0.255
network 23.1.1.0 0.0.0.255
auto-summary
eigrp stub connected leak-map EIGRP-MAP
No comments:
Post a Comment