MPLS Eigrp SOO
The EIGRP MPLS VPN PE-CE Site of Origin (SoO) feature introduces SoO support for EIGRP-to-BGP and BGP-to-EIGRP redistribution. The SoO extended community is a BGP extended community attribute that is used to identify routes that have originated from a site so that the re-advertisement of that prefix back to the source site can be prevented.
SoO filtering is configured at the interface level and is used to manage MPLS VPN traffic and to prevent routing loops from occurring in complex and mixed network topologies, such as EIGRP VPN sites that contain both VPN and back door links and Dual Home.
Version support EIGRP cost community, information is already incoded in the particular update and from customer point MPLS network is transparent portion of the EIGRP topology. Normally redistribution will look as external route in EIGRP, but is case of the MPLS this will be a regular route.
Site of Origin (SoO) filtering is configured at the interface level and is used to manage MPLS VPN traffic and to prevent transient routing loops from occurring in complex and mixed network topologies.The SoO extended community is defined on the interface of the backdoor router. It identifies the local site ID, which should match the value that is used on the PE routers that support the same site. When the backdoor router receives an EIGRP update (or reply) from a neighbor across the backdoor link, the router checks the update for an SoO value. If the SoO value in the EIGRP update matches the SoO value on the local backdoor interface, the route is rejected and not added to the EIGRP topology table.
R2 Config:
ip vrf CUST1
rd 1:5
route-target export 1:5
route-target import 1:5
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip vrf forwarding CUST1
ip address 12.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 23.1.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
router eigrp 100
auto-summary
!
address-family ipv4 vrf CUST1
redistribute bgp 100 metric 1 1 1 1 1
network 12.1.1.0 0.0.0.255
no auto-summary
autonomous-system 200
exit-address-family
!
router ospf 10
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 0
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
exit-address-family
!
address-family ipv4 vrf CUST1
redistribute eigrp 200
no synchronization
exit-address-family
!
R3 Config:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 23.1.1.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 34.1.1.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
R4 Config:
ip vrf CUST1
rd 1:5
route-target export 1:5
route-target import 1:5
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 34.1.1.4 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip vrf forwarding CUST1
ip address 45.1.1.4 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
auto-summary
!
address-family ipv4 vrf CUST1
redistribute bgp 100 metric 1 1 1 1 1
network 45.1.1.0 0.0.0.255
auto-summary
autonomous-system 200
exit-address-family
!
router ospf 10
log-adjacency-changes
network 4.4.4.0 0.0.0.255 area 0
network 34.1.1.0 0.0.0.255 area 0
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf CUST1
redistribute eigrp 200
no synchronization
exit-address-family
R1 Config:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 200
network 0.0.0.0
no auto-summary
R5 Config:
interface Loopback0
ip address 5.5.5.5 255.255.255.0
!
interface FastEthernet0/0
ip address 45.1.1.5 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 200
network 0.0.0.0
no auto-summary
we can see that the route to self loopback is being learned via the two paths one is directly connected and other is via the serial link, creating loop.
R2:
route-map SOO permit 10
set extcommunity soo 11:55
!
interface FastEthernet0/0
ip vrf forwarding CUST1
ip vrf sitemap SOO
ip address 12.1.1.2 255.255.255.0
duplex auto
speed auto
R4:
route-map SOO permit 10
set extcommunity soo 55:11
!
interface FastEthernet0/1
ip vrf forwarding CUST1
ip vrf sitemap SOO
ip address 45.1.1.4 255.255.255.0
duplex auto
speed auto
end
To not learn the same route via backdoor link SOO needs to be configure on the CE's, so that the matching SOO routes can be filtered from re-entering.
R1:
route-map SOO permit 10
set extcommunity soo 11:55
!
interface Serial1/0
ip vrf sitemap SOO
ip address 15.1.1.1 255.255.255.0
serial restart-delay 0
R5:
route-map SOO permit 10
set extcommunity soo 55:11
!
interface Serial1/0
ip vrf sitemap SOO
ip address 15.1.1.5 255.255.255.0
The EIGRP MPLS VPN PE-CE Site of Origin (SoO) feature introduces SoO support for EIGRP-to-BGP and BGP-to-EIGRP redistribution. The SoO extended community is a BGP extended community attribute that is used to identify routes that have originated from a site so that the re-advertisement of that prefix back to the source site can be prevented.
SoO filtering is configured at the interface level and is used to manage MPLS VPN traffic and to prevent routing loops from occurring in complex and mixed network topologies, such as EIGRP VPN sites that contain both VPN and back door links and Dual Home.
Version support EIGRP cost community, information is already incoded in the particular update and from customer point MPLS network is transparent portion of the EIGRP topology. Normally redistribution will look as external route in EIGRP, but is case of the MPLS this will be a regular route.
Site of Origin (SoO) filtering is configured at the interface level and is used to manage MPLS VPN traffic and to prevent transient routing loops from occurring in complex and mixed network topologies.The SoO extended community is defined on the interface of the backdoor router. It identifies the local site ID, which should match the value that is used on the PE routers that support the same site. When the backdoor router receives an EIGRP update (or reply) from a neighbor across the backdoor link, the router checks the update for an SoO value. If the SoO value in the EIGRP update matches the SoO value on the local backdoor interface, the route is rejected and not added to the EIGRP topology table.
R2 Config:
ip vrf CUST1
rd 1:5
route-target export 1:5
route-target import 1:5
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip vrf forwarding CUST1
ip address 12.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 23.1.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
router eigrp 100
auto-summary
!
address-family ipv4 vrf CUST1
redistribute bgp 100 metric 1 1 1 1 1
network 12.1.1.0 0.0.0.255
no auto-summary
autonomous-system 200
exit-address-family
!
router ospf 10
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 0
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
exit-address-family
!
address-family ipv4 vrf CUST1
redistribute eigrp 200
no synchronization
exit-address-family
!
R3 Config:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 23.1.1.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 34.1.1.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
R4 Config:
ip vrf CUST1
rd 1:5
route-target export 1:5
route-target import 1:5
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 34.1.1.4 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip vrf forwarding CUST1
ip address 45.1.1.4 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
auto-summary
!
address-family ipv4 vrf CUST1
redistribute bgp 100 metric 1 1 1 1 1
network 45.1.1.0 0.0.0.255
auto-summary
autonomous-system 200
exit-address-family
!
router ospf 10
log-adjacency-changes
network 4.4.4.0 0.0.0.255 area 0
network 34.1.1.0 0.0.0.255 area 0
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf CUST1
redistribute eigrp 200
no synchronization
exit-address-family
R1 Config:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 200
network 0.0.0.0
no auto-summary
R5 Config:
interface Loopback0
ip address 5.5.5.5 255.255.255.0
!
interface FastEthernet0/0
ip address 45.1.1.5 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 200
network 0.0.0.0
no auto-summary
Site of Origin (SoO) EIGRP
SoO is an extended community attribute used to prevent routing loops in
multi-honed MPLS customer sites by tagging and filtering prefixes before
being redistributed into the domain of origin.
we can see that the route to self loopback is being learned via the two paths one is directly connected and other is via the serial link, creating loop.
R2:
route-map SOO permit 10
set extcommunity soo 11:55
!
interface FastEthernet0/0
ip vrf forwarding CUST1
ip vrf sitemap SOO
ip address 12.1.1.2 255.255.255.0
duplex auto
speed auto
R4:
route-map SOO permit 10
set extcommunity soo 55:11
!
interface FastEthernet0/1
ip vrf forwarding CUST1
ip vrf sitemap SOO
ip address 45.1.1.4 255.255.255.0
duplex auto
speed auto
end
To not learn the same route via backdoor link SOO needs to be configure on the CE's, so that the matching SOO routes can be filtered from re-entering.
R1:
route-map SOO permit 10
set extcommunity soo 11:55
!
interface Serial1/0
ip vrf sitemap SOO
ip address 15.1.1.1 255.255.255.0
serial restart-delay 0
R5:
route-map SOO permit 10
set extcommunity soo 55:11
!
interface Serial1/0
ip vrf sitemap SOO
ip address 15.1.1.5 255.255.255.0
No comments:
Post a Comment