MPLS RIP Config
R2 Config:-
ip vrf CUST1
rd 1:5
route-target export 1:5
route-target import 1:5
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip vrf forwarding CUST1
ip address 12.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 23.1.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 10
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 0
!
router rip
version 2
!
address-family ipv4 vrf CUST1
redistribute bgp 100 metric 1
network 12.0.0.0
no auto-summary
exit-address-family
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
exit-address-family
!
address-family ipv4 vrf CUST1
redistribute rip
no synchronization
exit-address-family
!
R3 Config:-
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 23.1.1.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 34.1.1.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
R4 Config:-
ip vrf CUST1
rd 1:5
route-target export 1:5
route-target import 1:5
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 34.1.1.4 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip vrf forwarding CUST1
ip address 45.1.1.4 255.255.255.0
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 4.4.4.0 0.0.0.255 area 0
network 34.1.1.0 0.0.0.255 area 0
!
router rip
version 2
!
address-family ipv4 vrf CUST1
redistribute bgp 100 metric 1
network 45.0.0.0
no auto-summary
exit-address-family
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf CUST1
redistribute rip
no synchronization
exit-address-family
R1 Config:-
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 1.0.0.0
network 12.0.0.0
no auto-summary
R5 Config:-
interface Loopback0
ip address 5.5.5.5 255.255.255.0
!
interface FastEthernet0/0
ip address 45.1.1.5 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 5.0.0.0
network 45.0.0.0
no auto-summary
Routing table output R5
Ping from R5 to R1 and trace output
R2 Config:-
ip vrf CUST1
rd 1:5
route-target export 1:5
route-target import 1:5
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip vrf forwarding CUST1
ip address 12.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 23.1.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 10
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 0
!
router rip
version 2
!
address-family ipv4 vrf CUST1
redistribute bgp 100 metric 1
network 12.0.0.0
no auto-summary
exit-address-family
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
exit-address-family
!
address-family ipv4 vrf CUST1
redistribute rip
no synchronization
exit-address-family
!
R3 Config:-
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 23.1.1.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 34.1.1.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
R4 Config:-
ip vrf CUST1
rd 1:5
route-target export 1:5
route-target import 1:5
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 34.1.1.4 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip vrf forwarding CUST1
ip address 45.1.1.4 255.255.255.0
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 4.4.4.0 0.0.0.255 area 0
network 34.1.1.0 0.0.0.255 area 0
!
router rip
version 2
!
address-family ipv4 vrf CUST1
redistribute bgp 100 metric 1
network 45.0.0.0
no auto-summary
exit-address-family
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf CUST1
redistribute rip
no synchronization
exit-address-family
R1 Config:-
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 1.0.0.0
network 12.0.0.0
no auto-summary
R5 Config:-
interface Loopback0
ip address 5.5.5.5 255.255.255.0
!
interface FastEthernet0/0
ip address 45.1.1.5 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 5.0.0.0
network 45.0.0.0
no auto-summary
Routing table output R5
Ping from R5 to R1 and trace output
No comments:
Post a Comment