EIGRP supports MD5 authentication in Classic Mode, and both MD5 and SHA-256 in Named Mode. For MD5 authentication in both Classic and Named modes, the key chain is defined globally.
R1(config)#
!
key chain EIGRP-MD5
key 1
key-string MYPASS
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 EIGRP-MD5
duplex auto
speed auto
!
router eigrp 100
network 1.0.0.0
network 12.0.0.0
no auto-summary
R2#
!
key chain EIGRP-MD5
key 1
key-string MYPASS
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.2 255.255.255.0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 EIGRP-MD5
duplex auto
speed auto
!
router eigrp 100
network 2.0.0.0
network 12.0.0.0
no auto-summary
!
R1(config)#
!
key chain EIGRP-MD5
key 1
key-string MYPASS
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 EIGRP-MD5
duplex auto
speed auto
!
router eigrp 100
network 1.0.0.0
network 12.0.0.0
no auto-summary
R2#
!
key chain EIGRP-MD5
key 1
key-string MYPASS
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.2 255.255.255.0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 EIGRP-MD5
duplex auto
speed auto
!
router eigrp 100
network 2.0.0.0
network 12.0.0.0
no auto-summary
!
No comments:
Post a Comment