EIGRP
The network statement in EIGRP, like in OSPF, does not control which networks are being advertised, but instead controls which interfaces are running the EIGRP process. Using a wildcard address of 0.0.0.0 in the EIGRP network statement, only the interface with that particular IPv4 address will have the EIGRP process enabled. By using all zeros in the wildcard mask, there is no question as to which interfaces are running the process, and new interfaces added to the device will not automatically be running the EIGRP process.
R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
ip address 11.11.11.11 255.255.255.0
!
interface Loopback2
ip address 111.111.111.111 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 100
network 1.0.0.0
network 11.0.0.0
network 12.0.0.0
network 111.0.0.0
!
R2#
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
network 12.0.0.0
!
R1# router eigrp 100
no auto-summary
R1# auto-summary
The network statement in EIGRP, like in OSPF, does not control which networks are being advertised, but instead controls which interfaces are running the EIGRP process. Using a wildcard address of 0.0.0.0 in the EIGRP network statement, only the interface with that particular IPv4 address will have the EIGRP process enabled. By using all zeros in the wildcard mask, there is no question as to which interfaces are running the process, and new interfaces added to the device will not automatically be running the EIGRP process.
R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
ip address 11.11.11.11 255.255.255.0
!
interface Loopback2
ip address 111.111.111.111 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 100
network 1.0.0.0
network 11.0.0.0
network 12.0.0.0
network 111.0.0.0
!
R2#
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
network 12.0.0.0
!
R1# router eigrp 100
no auto-summary
R1# auto-summary
No comments:
Post a Comment