Class Based Weighted Fair Queuing
Http Should get bandwidth 20 and queue limit should be 10 packets
Telnet should get bw 80 and queue limit should be 20 packets
By default we can reserve 75% of the interface bandwidth for QOS, if you will try to reserve more than that you will get the below error
to allocate the bandwidth more than 75% you need to configure max-reserved-bandwidth 100 on the interface.
R2 Config:
ip access-list extended http
permit tcp any any eq www
ip access-list extended telnet
permit tcp any any eq telnet
!
class-map match-all TELNET
match access-group name telnet
class-map match-all HTTP
match access-group name http
!
!
policy-map CLASS-BASED-WFQ
class HTTP
bandwidth 20
queue-limit 10
class TELNET
bandwidth 80
queue-limit 20
!
interface Serial1/0
bandwidth 128
ip address 23.1.1.2 255.255.255.0
serial restart-delay 0
max-reserved-bandwidth 100
service-policy output CLASS-BASED-WFQ
Now try to telnet R4 from R1 and see the packets are matching the Telnet Class and same in the case when we are accessing R4 over the port 80(http)
No comments:
Post a Comment