QOS Classification and Marking
Task is to match the HTTP packets originating from R1 to mark dscp cs4 and see that the traffic is matching at R4.
R1 Config
ip access-list extended HTTP
permit tcp any any eq www
!
class-map match-all CMAP-HTTP
match access-group name HTTP
!
!
policy-map POLICY-HTTP
class CMAP-HTTP
set dscp cs4
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
service-policy output POLICY-HTTP
Make R4 as http serve to accept the traffic and configure access-list to check the http traffic with dscp cs4
R4 Config
ip http server
!
interface FastEthernet0/0
ip address 34.1.1.4 255.255.255.0
ip access-group MATCH-HTTP in
duplex auto
speed auto
!
ip access-list extended MATCH-HTTP
permit tcp any any dscp cs4
permit ip any any
Lets generate some http traffic towards R4
Check traffic in R4
Task is to match the HTTP packets originating from R1 to mark dscp cs4 and see that the traffic is matching at R4.
R1 Config
ip access-list extended HTTP
permit tcp any any eq www
!
class-map match-all CMAP-HTTP
match access-group name HTTP
!
!
policy-map POLICY-HTTP
class CMAP-HTTP
set dscp cs4
!
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
service-policy output POLICY-HTTP
Make R4 as http serve to accept the traffic and configure access-list to check the http traffic with dscp cs4
R4 Config
ip http server
!
interface FastEthernet0/0
ip address 34.1.1.4 255.255.255.0
ip access-group MATCH-HTTP in
duplex auto
speed auto
!
ip access-list extended MATCH-HTTP
permit tcp any any dscp cs4
permit ip any any
Lets generate some http traffic towards R4
Check traffic in R4
No comments:
Post a Comment